Contact Me

If you are looking for support with some of my software:

  • Please ensure that you have read the documentation thoroughly.
  • Please ensure that you are using the latest release as downloadable from this web page, and that your computer meets the system requirements. I'm sorry, but I cannot support obsolete releases.
  • Please be sure to specify which software program you need help with. This may seem obvious, but you'd be surprised how many users forget to include this information!
  • Cacophony is not compatible with Mac OS X 10.7 and later.

Finally, please bear in mind that I often go for several days without seeing my e-mail. Please be patient.






CAPTCHA Image - if you cannot see this, please contact me for advice